Discussion Forums  >  App Store Rejections

Replies: 12    Views: 373

Djdios
Lost but trying
Profile
Posts: 175
Reg: Mar 20, 2013
Valby, Denmark
3,550
06/26/14 11:25 PM (8 years ago)

App rejected: Video playback don't work?

Hi Everybody I thought I had everything in place and my app would be accepted right away, but that didnt happen. As many of you Ive spend heaps amount of time on developing this app and its really frustrating to get it rejected. The rejection is based on the following: 2.2 ??We found that your app exhibited one or more bugs, when reviewed on iPad running iOS 7.1.1 and iPhone 5s running iOS 7.1.1, on both Wi-Fi and cellular networks, which is not in compliance with the App Store Review Guidelines.??Specifically, we found that we were unable to get the videos to play within your application. When we tapped on the play button there was no action and no video was played even after waiting for several minutes. Please see the attached screenshot for more information.??For discrete code-level questions, you may wish to consult with Apple Developer Technical Support. When the DTS engineer follows up with you, please be ready to provide:??- complete details of your rejection issue(s)?- screenshots?- steps to reproduce the issue(s)?- symbolicated crash logs - if your issue results in a crash log??If you have difficulty reproducing a reported issue, please try testing the workflow as described in <https://developer.apple.com/library/ios/qa/qa1764/>Technical Q&A QA1764: How to reproduce a crash or bug that only App Review or users are seeing. Okay so first of all my app should be offline, its all packed within the app. Ive tested the app on my 5s and iPad Air with iOS 7.1.1 with no error. It did have some errors I wrote about in this forum ( ) but it wouldnt affect anything. I followed GoNothWest tutorial for submitting apps and the only thing that varied from my process was the archiving. When archiving I had the simulator on iOS Device and then chose archive. In organizer I then chose distribute when the app was archived (think it was compressed to 1/3 of its original size). The weird think for me is that they send a screenshot thats totally irrelevant and not useable for anything, I could make the same screenshot. So one starts to think is this for real the app doesnt work or is it because they dont want the app on the appstore ? Could someone please help me with the next steps? Im so close now I can taste it.
 
AlanMac
Aspiring developer
Profile
Posts: 2612
Reg: Mar 05, 2012
Esher, UK
37,120
Fourm StarFourm StarFourm Star
like
06/27/14 01:43 AM (8 years ago)
Ho @Djdios, the first step is to reproduce the problem. Apple are saying the problem is the app doesn't do what it should, (i.e. play video's), so I suggest you home in on that and convince yourself it works on a couple of devices. On the point you make about archiving, if you got it to work, you are probably doing it correctly. Just be sure the step before archive is a test on a simulator or device to be sure you didn't miss anything in he final packaging. If you are convinced that your app works the way you think, you can try a dialogue with the reviewer. I just had a an app approved after being rejected twice - hang in there!
 
Bonzo
Apple Fan
Profile
Posts: 775
Reg: Jan 30, 2012
Basingstoke
13,450
Fourm StarFourm Star
like
06/27/14 03:32 AM (8 years ago)
could it just be an out of date BT_config.txt in xcode? im guessing you downloaded from BT early on and had it in xcode whilst you were still working on the project and making changes. This is now working for you because you've been refreshing each time. But the config.txt doesnt update in xcode, so you probably archived and submitted the app with the original config.txt? so when apple run, they have the original config and would need to refresh to bring it up to speed? Before i submit, i copy the latest JSON from BT and overwrite whats in my config file. i guess it could be a possible issue? i'd delete from your phone and then run on the phone whilst connected to xcode. when it loads, DO NOT refresh and then try and run the videos in question....?
 
Djdios
Lost but trying
Profile
Posts: 175
Reg: Mar 20, 2013
Valby, Denmark
3,550
like
06/27/14 03:54 AM (8 years ago)
Hi AlanMAc And Bonzo. Thank you for your replies. Bonzo I think you are on to something. I just changed the config file from design to live, nothing else. So what I need to do is, copy the config file from control panel live mode, then paste it to my Xcode project. Run a test on my devices, if that works then archive and resubmit it?
 
Bonzo
Apple Fan
Profile
Posts: 775
Reg: Jan 30, 2012
Basingstoke
13,450
Fourm StarFourm Star
like
06/27/14 04:36 AM (8 years ago)
go into your app on BT control panel/sef hosted control panel and go to the JSON data section. select all and copy, and then delete everything in BTconfig.txt in xcode and paste the JSON values then archive and run
 
Djdios
Lost but trying
Profile
Posts: 175
Reg: Mar 20, 2013
Valby, Denmark
3,550
like
06/27/14 05:07 AM (8 years ago)
So I did what you wrote and everything works on my phone and on the sim. Should that be it, and then re-upload to apple?
 
Bonzo
Apple Fan
Profile
Posts: 775
Reg: Jan 30, 2012
Basingstoke
13,450
Fourm StarFourm Star
like
06/27/14 05:18 AM (8 years ago)
id give it a go
 
Djdios
Lost but trying
Profile
Posts: 175
Reg: Mar 20, 2013
Valby, Denmark
3,550
like
06/27/14 05:43 AM (8 years ago)
Just uploaded it. So now it's a wait of 7 days again:( Let's see if they accept it this time. Thank you so much for your assistance.
 
Bonzo
Apple Fan
Profile
Posts: 775
Reg: Jan 30, 2012
Basingstoke
13,450
Fourm StarFourm Star
like
06/27/14 05:48 AM (8 years ago)
lets hope it was the cause. current average is 6 days (twitter - @appreviewtimes)
 
AlanMac
Aspiring developer
Profile
Posts: 2612
Reg: Mar 05, 2012
Esher, UK
37,120
Fourm StarFourm StarFourm Star
like
06/27/14 06:47 AM (8 years ago)
On my last app, it was rejected for the content, even after I had updated content, because Apple did not do an app refresh.
 
Djdios
Lost but trying
Profile
Posts: 175
Reg: Mar 20, 2013
Valby, Denmark
3,550
like
06/27/14 07:57 AM (8 years ago)
So what was your solution to that problem AlanMac?
 
AlanMac
Aspiring developer
Profile
Posts: 2612
Reg: Mar 05, 2012
Esher, UK
37,120
Fourm StarFourm StarFourm Star
like
06/27/14 08:03 AM (8 years ago)
In my case, I noticed something, after I had submitted the binary, so I made the change in the control panel before the app went into review. Apple picked up on the old version in review. I wrote back to explain they could click refresh, but they had already rejected the binary. So I did exactly as @Bonzo suggested, made absolutely sure the latest config.txt was in the archive build and resubmitted the binary. Noting else had to be changed and they approved the app (yesterday). There is hope.
 
aquila198
buzztouch Evangelist
Profile
Posts: 473
Reg: Jul 22, 2011
location unknow...
10,330
Fourm StarFourm Star
like
06/27/14 06:39 PM (8 years ago)
congrats on your success story AlanMac! Best of luck Djdios - i know it can be frustrating.. you'll get there.
 

Login + Screen Name Required to Post

pointerLogin to participate so you can start earning points. Once you're logged in (and have a screen name entered in your profile), you can subscribe to topics, follow users, and start learning how to make apps like the pros.