Discussion Forums  >  Basics, How it Works, Is it free?

Replies: 18    Views: 102

Worker73
Android Fan
Profile
Posts: 419
Reg: Feb 06, 2012
Austria, Klagen...
4,490
04/25/16 11:37 PM (2 years ago)

BT Best compatibility with WHAT combination?

Hi All...

Im trying to work out what Combination is the best for Android development....

Can somebody help me out?

1. Self Hosted with Android Studio?
2. Self Hosted with Eclipse?
3. Buzztouch Panel with Android Studio?
4. Buzztouch Panel with Eclipse?

With what combination is the best for the PlugIns from here and the Code?

Thanks for help...
 
Dusko
Veteran developer
Profile
Posts: 998
Reg: Oct 13, 2012
Beograd
22,680
like
04/26/16 01:02 AM (2 years ago)
1. Self Hosted with Android Studio
 
Worker73
Android Fan
Profile
Posts: 419
Reg: Feb 06, 2012
Austria, Klagen...
4,490
like
04/26/16 01:36 AM (2 years ago)
Thanks Dusko....
Any other also?
 
SmugWimp
Smugger than thou...
Profile
Posts: 6316
Reg: Nov 07, 2012
Tamuning, GU
81,410
like
04/26/16 02:02 AM (2 years ago)
1) Eclipse is being retired. No sense in learning or maintaining a platform that will be leaving.
2) Self hosted provides more autonomy in development. You're not tied to any one person or place. you can modify pieces to suit your needs.

For those, as well as other reasons, I echo Dusko.

Cheers!

-- Smug
 
Worker73
Android Fan
Profile
Posts: 419
Reg: Feb 06, 2012
Austria, Klagen...
4,490
like
04/26/16 03:01 AM (2 years ago)
I have Self Hosted and Android Studio (Newest 2.0) but i cant compile because there are so much Errors... ( Ifollow the YT Step by Step from Mark on: https://www.youtube.com/watch?v=LsLTfaajeqg)

What Setup have you in your "build.gradle"?

compileSdkVersion ??
buildToolsVersion ??
minSdkVersion ??
targetSdkVersion ??

What depencies?
 
Dusko
Veteran developer
Profile
Posts: 998
Reg: Oct 13, 2012
Beograd
22,680
like
04/26/16 03:10 AM (2 years ago)
Other people also have the same problems. Here are a few recent threads on the subject:

http://www.buzztouch.com/forum/thread.php?fid=EF5D98C7B9BA6E06DADC0A3&tid=EF5D98C7B9BA6E06DADC0A3

And here is my build.gradle (module) file:

http://www.buzztouch.com/forum/thread.php?tid=5C9E15AC1C633FB912BE79A&currentPage=1

>i cant compile because there are so much Errors...

Show us your errors, one by one so that we can help you fix them.
 
Worker73
Android Fan
Profile
Posts: 419
Reg: Feb 06, 2012
Austria, Klagen...
4,490
like
04/26/16 03:30 AM (2 years ago)
Okay... i have the same gradle Settings:
compileSdkVersion 14
buildToolsVersion '23.0.2'
minSdkVersion 14
targetSdkVersion 14

compile files('libs/gcm.jar')
compile files('libs/YouTubeAndroidPlayerApi.jar')
compile 'com.google.android.gms:play-services:8.4.0'
compile 'com.android.support:support-v4:+'
compile 'com.android.support:appcompat-v7:+'
compile 'com.google.android.gms:play-services-ads:8.4.0'

My Errors on Compile (For Emulator):

(1)

C:\001\MyApp-Android-BTv3.01\app\build\intermediates\res\merged\debug\values-ldltr-v21\values-ldltr-v21.xml
Error:(3) Error retrieving parent for item: No resource found that matches the given name 'android:Widget.Material.Spinner.Underlined'.

(2)
C:\001\MyApp-Android-BTv3.01\app\build\intermediates\exploded-aar\com.android.support\appcompat-v7\24.0.0-alpha2\res\values-v17\values-v17.xml
Error:(3, 5) No resource found that matches the given name: attr 'android:textAlignment'.
...
...
...
and so on...
 
Dusko
Veteran developer
Profile
Posts: 998
Reg: Oct 13, 2012
Beograd
22,680
like
04/26/16 05:26 AM (2 years ago)
As shown in the other thread, my build.gradle look like this:

====================
apply plugin: 'com.android.application'

android {
compileSdkVersion 14
buildToolsVersion "23.0.2"

defaultConfig {
applicationId "com.xxxxxxxxxxxx"
minSdkVersion 14
targetSdkVersion 14
}

buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
}
}
}

dependencies {
compile files('libs/gcm.jar')
compile 'com.google.android.gms:play-services-ads:8.4.0'
}

====================

Try that. Why do you have these two lines:

compile 'com.android.support:support-v4:+'
compile 'com.android.support:appcompat-v7:+'

They serve for backward compatibility and if you are creating a new BT project, you won't need them.

Less is maybe better than more in this case.
 
SmugWimp
Smugger than thou...
Profile
Posts: 6316
Reg: Nov 07, 2012
Tamuning, GU
81,410
like
04/26/16 05:53 AM (2 years ago)
I fought and fought moving to Android Studio. So many errors, and Eclipse seemed so easy.

I finally sat down and worked my way through the issues, because I knew I would have to sooner or later.

I'm kind of surprised my gradle file looks very similar to Dusko's...

apply plugin: 'com.android.application'

android {
compileSdkVersion 23
buildToolsVersion "23.0.2"
useLibrary 'org.apache.http.legacy'

defaultConfig {
applicationId "com.smugplug"
multiDexEnabled true
minSdkVersion 14
targetSdkVersion 14
}

buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
}
}
}

dependencies {
compile files('libs/gcm.jar')
compile 'com.google.android.gms:play-services:+'
}

When I've gotten those mysterious 'not connected with anything I'm doing' errors, I tend to play with the min and target SDK version, although I'm not entirely sure if that will fix things or not.

I'm not acquainted enough with Android the way I am with iOS, so a lot of times my efforts are reduced to 'banging on the side' to see if it fixes the problem. But again, echoing Dusko, let us know what the specific errors are, and we'll do our best to work through them.

Cheers!

-- Smug
 
Worker73
Android Fan
Profile
Posts: 419
Reg: Feb 06, 2012
Austria, Klagen...
4,490
like
04/26/16 05:57 AM (2 years ago)
OH MY GOD!
Ive seen ONE THING, that could be the Key!!!
 
Worker73
Android Fan
Profile
Posts: 419
Reg: Feb 06, 2012
Austria, Klagen...
4,490
like
04/26/16 07:10 AM (2 years ago)
@SmugWimp: YOU ARE MY HERO!!!

Two little Things and all is Running like a Charm....

1) Insert in the "build.gradle" the Statement:

useLibrary 'org.apache.http.legacy'

2) Delete in the main/AndroidManifest.xml (Line 60):

android:debuggable="false">

My Settings in the build.gradle:

apply plugin: 'com.android.application'

android {
compileSdkVersion 23
buildToolsVersion "23.0.2"
useLibrary 'org.apache.http.legacy'

defaultConfig {
applicationId "com.YOURAPPNAME"
minSdkVersion 14
targetSdkVersion 14
}

buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
}
}
}

dependencies {
compile files('libs/gcm.jar')
compile files('libs/YouTubeAndroidPlayerApi.jar')
compile 'com.google.android.gms:play-services:8.4.0'
compile 'com.google.android.gms:play-services-ads:8.4.0'
}
 
Dusko
Veteran developer
Profile
Posts: 998
Reg: Oct 13, 2012
Beograd
22,680
like
04/26/16 07:37 AM (2 years ago)
Great that you've solved you problems, however, the story does not end there.

Library org.apache.http.legacy is deprecated as of version 23, not depending on it will help you in the long run. You may also get a notification from Google, as in this thread:

http://50.57.191.212/forum/thread.php?tid=BF50F4B61C83A1EE3A12B77

In short, you need to remove the deprecated code not later than the 17th of May 2016, that is, a few weeks from now.
 
Worker73
Android Fan
Profile
Posts: 419
Reg: Feb 06, 2012
Austria, Klagen...
4,490
like
04/26/16 08:39 AM (2 years ago)
Yes... but thats a "Buzztouch Team " and "PlugIn-Developer" Problem...
Because "Buzztouch" use it for connecting to the Panel and the PlugIn Dev`s also... So i hope there comes an Update soon...
 
CMCOFFEE
Android Fan
Profile
Posts: 2017
Reg: Jan 04, 2013
Amarillo, Texas
26,670
like
04/28/16 06:10 PM (2 years ago)
I posted a easy fix for that a couple weeks ago I think.

http://www.buzztouch.com/forum/thread.php?tid=3A450CCA73A0B8ADEA40EA3&command=isSearching&currentPage=1&topicTitle=&createdBy=Cmcoffee&repliedBy=&minViews=-1&maxViews=-1&minReplies=-1&maxReplies=-1&forumCategory=

I'm submitting both the pic gallery and YouTube plugin with the updated code and continuous scrolling also. Instead of waiting for the all the images or videos to load. I also add iOS versions on the same plugins, because it made it easier for me than using two different plugins
 
CMCOFFEE
Android Fan
Profile
Posts: 2017
Reg: Jan 04, 2013
Amarillo, Texas
26,670
like
04/28/16 06:11 PM (2 years ago)
Will submit the updates Saturday, because I want to add animation to the plugins too
 
Worker73
Android Fan
Profile
Posts: 419
Reg: Feb 06, 2012
Austria, Klagen...
4,490
like
04/29/16 12:56 AM (2 years ago)
Sounds Great! Thanks!
 
Jos Abroad
Lost but trying
Profile
Posts: 8
Reg: Jan 16, 2017
Überlingen
80
like
02/28/17 03:04 AM (2 years ago)
Hi,

Okay, so reading through this thread, I am really wondering how it should be possible that I can do this all without any coding knowledge? I have been through a few of GoNorthwest's tutorials and get fudged up somewhere along the way and can't bring myself to try further. Especially when I see threads like this... Getting ready to throw in the towel and see if I can find a developer who's willing to work for free on a project that may never get picked up. Oh, shit... that might not work...

So, in that case, any words of wisdom? I wonder if there's anyone in my region who wants to (stay free in my private holiday apartment with a separate entrance here at beautiful Lake Constance) help get me started? I really think if I could just get a boost in the beginning, I could figure this out! I'm only half-joking...

....help!

Cheers!
Jo
 
SmugWimp
Smugger than thou...
Profile
Posts: 6316
Reg: Nov 07, 2012
Tamuning, GU
81,410
like
03/01/17 07:43 PM (2 years ago)
I'll be honest, with respect to Android, it's a little tough. So many moving parts, so many 'by the way' details to keep in mind.

No coding seems to work great on iOS; nab a few plugins, a menu, some content, and you're on your way.

Android seems to require a bit more care and feeding, and not always easy, even to an experienced person.

Persistence is the key. there are a lot of BT members who publish with android, but I'm not sure what their secrets are. I follow Dusko's blog, and other Android sources, to try and keep abreast of the odd changes that come about. That's really all I can say. I wish you the best.

BTW, this is probably my last BT post for a bit; I've let my membership lapse, and it looks as if my access will be cut off in a day or so.

Good Luck, and enjoy!

Cheers!

-- Smug
 
Jos Abroad
Lost but trying
Profile
Posts: 8
Reg: Jan 16, 2017
Überlingen
80
like
03/02/17 12:46 AM (2 years ago)
Thanks, Smug.

I think that I will continue to give it a try. I guess I've paid for my year now, but it appears for my skill level/needs, I might've spent it better elsewhere.

It's a pity that you won't be around since I've not had much response from others so far and I've appreciated your feedback.

Take care!!

Jo
 

Login + Screen Name Required to Post

pointerLogin to participate so you can start earning points. Once you're logged in (and have a screen name entered in your profile), you can subscribe to topics, follow users, and start learning how to make apps like the pros.