Discussion Forums  >  Self Hosted Control Panels

Replies: 14    Views: 216

DougJoseph
Aspiring developer
Profile
Posts: 161
Reg: Jan 30, 2016
Stonewood
2,210
02/13/16 12:04 PM (6 years ago)

Self hosted - session ends moment I try to download any project

My problem is not exactly the same as this: https://www.buzztouch.com/forum/thread.php?fid=5607B0F82171ABAD76A4C42&tid=5607B0F82171ABAD76A4C42 ..or exactly the same as this: https://www.buzztouch.com/forum/thread.php?tid=063F4499EC79790B8DCAEDC Here is a screenshot of what instantly happens each time I try to download a project: https://www.buzztouch.com/applications063014/JAE2BA43AAF691CCE0896DF22/images/Screen%20Shot%202016-02-13%20at%201.44.14%20PM.png I installed BT-Server, then upgraded my hosting to Bluehost's "Cloud Business Pro" plan, and switched to a dedicated IP. I then made sure the new dedicated IP was shown here in my self-hosting parameters. I am trying the project download on both pre-existing and new projects, and on the pre-existing, it was something I was previously able to download successfully. It's been about 12 hours since the switch to the dedicated IP address, and the site has been responding to the new IP since very quickly after the switch. Anyone have any tips or ideas that could help me?
 
DougJoseph
Aspiring developer
Profile
Posts: 161
Reg: Jan 30, 2016
Stonewood
2,210
like
02/13/16 12:12 PM (6 years ago)
I should add: The hosting switch changed my "Application Install Physical Path" from "home3/..." to "home2/..." but I already made that change to my config.php file, and I am still having issue of session ending instantly when I try to download. Looking at re-installing BT-Server now to see if that helps.
 
DougJoseph
Aspiring developer
Profile
Posts: 161
Reg: Jan 30, 2016
Stonewood
2,210
like
02/13/16 12:24 PM (6 years ago)
I should also add: The site builds the package and offers it for download. That part works just fine. It is the moment I click to actually download, that's when my session ends and I get booted back the log in screen.
 
DougJoseph
Aspiring developer
Profile
Posts: 161
Reg: Jan 30, 2016
Stonewood
2,210
like
02/13/16 12:30 PM (6 years ago)
I tried re-running the install, and it showed all things correct and working, but the same problem persists.
 
DougJoseph
Aspiring developer
Profile
Posts: 161
Reg: Jan 30, 2016
Stonewood
2,210
like
02/13/16 11:02 PM (6 years ago)
Anyone?
 
Dusko
Veteran developer
Profile
Posts: 998
Reg: Oct 13, 2012
Beograd
22,680
Fourm StarFourm StarFourm Star
like
02/13/16 11:56 PM (6 years ago)
>The hosting switch changed my "Application Install Physical Path" from "home3/..." to "home2/..." but I already made that change to my config.php file, and I am still having issue of session ending instantly when I try to download. That behavior would be typical of any password protected system based on cookies. So, one idea is to check whether you have cookies set up properly. Looking at the config.php file for BT server installation, I see this comment: /* Cookie names are unique to this installation and must be unique values such as a GUID */ Please check that these are unique indeed. Two other ideas: ask your hosting support to explore why your BT installation will not work after THEY changed something in your account. BT server is open source so you can insert echo statements into file /bt_v15/bt_app/bt_appPackage.php and see exactly at which point are you being shut out from the system. That should give you some idea of what to do next.
 
Annonymous
Profile
02/14/16 03:17 AM (6 years ago)
I am now trying a combination of flushing my local cache and editing those cookie names. Will report back!
 
DougJoseph
Aspiring developer
Profile
Posts: 161
Reg: Jan 30, 2016
Stonewood
2,210
like
02/14/16 03:18 AM (6 years ago)
I am now trying a combination of flushing my local cache and editing those cookie names. Will report back!
 
DougJoseph
Aspiring developer
Profile
Posts: 161
Reg: Jan 30, 2016
Stonewood
2,210
like
02/14/16 03:28 AM (6 years ago)
Now the funny thing is, I went to change the ownership of the app back to me, and the change of ownership won't stick! Ugh.
 
Dusko
Veteran developer
Profile
Posts: 998
Reg: Oct 13, 2012
Beograd
22,680
Fourm StarFourm StarFourm Star
like
02/14/16 03:39 AM (6 years ago)
>the change of ownership won't stick The installation of BT server seems flawed. Have a look at the table bt_app_users in your BT database installation. There is a column userType and it has value owner or normal. See whether the database changes when you change the ownership from BT control panel. Also, see what you have in table bt_users.
 
DougJoseph
Aspiring developer
Profile
Posts: 161
Reg: Jan 30, 2016
Stonewood
2,210
like
02/14/16 03:50 AM (6 years ago)
OK, thanks. I think part of it is the hosting is doing some kind of caching that causes changes to be delayed in showing up. I am looking into that. The ownership changes showed up after a delay. However, the session ending instantly when I try to download the project is still happening.
 
Dusko
Veteran developer
Profile
Posts: 998
Reg: Oct 13, 2012
Beograd
22,680
Fourm StarFourm StarFourm Star
like
02/14/16 04:23 AM (6 years ago)
Insert echo statements into /bt_v15/bt_app/bt_appPackage.php and see what it tells you. I'd insert an echo statement literally after each line of PHP code -- that ought to tell you where you are expelled, and then, why. I'd also talk to hosting support and ask them to reverse the change they did.
 
DougJoseph
Aspiring developer
Profile
Posts: 161
Reg: Jan 30, 2016
Stonewood
2,210
like
02/14/16 05:13 AM (6 years ago)
OK, thanks.
 
SmugWimp
Smugger than thou...
Profile
Posts: 6316
Reg: Nov 07, 2012
Tamuning, GU
81,410
Fourm StarFourm StarFourm Star
like
02/14/16 08:26 AM (6 years ago)
Sometimes when something in Self Hosted isn't working right, it's because the physical path is incorrect. Make sure it's correct; if possible make sure your hosting provider can confirm your values. Cheers! -- Smug
 
DougJoseph
Aspiring developer
Profile
Posts: 161
Reg: Jan 30, 2016
Stonewood
2,210
like
02/14/16 10:44 PM (6 years ago)
OK, I have good news. I was finally able to track down the issue. It was the hosting company's caching service. Bluehost's caching service is called "Varnish." As soon as I turned that off on the domain where I am self hosting BT, the issue went away. Problem solved!
 

Login + Screen Name Required to Post

pointerLogin to participate so you can start earning points. Once you're logged in (and have a screen name entered in your profile), you can subscribe to topics, follow users, and start learning how to make apps like the pros.