Tyroner
Aspiring developer
Profile
Posts: 175
Reg: Dec 26, 2012
Johannesburg, S...
4,200
Fourm Star
04/22/16 10:54 AM (6 years ago)

Android Studio Errors

Hi guys This Android Studio is a beast. I keep on getting errors! These are the latest! Error:(3) Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Inverse'. Error:(18) Error retrieving parent for item: No resource found that matches the given name 'android:Widget.Material.Button.Colored'. Error:Execution failed for task ':app:processDebugResources'. > com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command '/Users/tyronerichards/Library/Android/sdk/build-tools/21.1.2/aapt'' finished with non-zero exit value 1 Not sure how to proceed! I am using Android Studio 2.0 using Buzztouch Control Panel. I have API 14, 21, 22 and 23 installed. I am compiling for API 21 and Build Tool version 21.1.2 Thanks for all the help Tyrone
 
Dusko
Veteran developer
Profile
Posts: 998
Reg: Oct 13, 2012
Beograd
22,680
Fourm StarFourm StarFourm Star
like
04/23/16 12:21 AM (6 years ago)
Well, the proper procedure to debug problem like this is to take the description of the problem, search for it trough Google and something will come up. In this case, I copied and pasted the following sentence: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Inverse' Out comes a Google listing for that long, long, long phrase and it turns out that many people already had that problem, and that all of them have already solved it. I clicked on the first link in the results, and got to this page: http://stackoverflow.com/questions/32075498/error-retrieving-parent-for-item-no-resource-found-that-matches-the-given-name From there we see that if you have version 23 installed, it needs to be taken into account and that you have to match everything else to it. One of the solutions on that page will surely solve your problem.
 
Worker73
Android Fan
Profile
Posts: 419
Reg: Feb 06, 2012
Austria, Klagen...
4,490
like
04/26/16 07:12 AM (6 years ago)
@Tyroner: Ive solved the Problem with this Steps: Two little Things and all is Running like a Charm.... 1) Insert in the "build.gradle" the Statement: useLibrary 'org.apache.http.legacy' 2) Delete in the main/AndroidManifest.xml (Line 60): android:debuggable="false"> My Settings in the build.gradle: apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion "23.0.2" useLibrary 'org.apache.http.legacy' defaultConfig { applicationId "com.YOURAPPNAME" minSdkVersion 14 targetSdkVersion 14 } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } } dependencies { compile files('libs/gcm.jar') compile files('libs/YouTubeAndroidPlayerApi.jar') compile 'com.google.android.gms:play-services:8.4.0' compile 'com.google.android.gms:play-services-ads:8.4.0' }
 
mysps
Code is Art
Profile
Posts: 2082
Reg: May 14, 2011
Palma
33,320
Fourm StarFourm StarFourm Star
like
07/09/16 10:08 AM (6 years ago)
Thanks for that solution Worker ;) Finally getting some android apps updated!
 

Login + Screen Name Required to Post

pointerLogin to participate so you can start earning points. Once you're logged in (and have a screen name entered in your profile), you can subscribe to topics, follow users, and start learning how to make apps like the pros.