Discussion Forums  >  Uncategorized

Replies: 8    Views: 1817

The Fort Wayne Bride
Aspiring developer
Profile
Posts: 35
Reg: Jan 24, 2012
Fort Wayne, IN
350
02/17/12 01:59 PM (10 years ago)

R cannot be resolved as a variable

Okay the title is my problem. I have added my project to eclipse tried running it, but it is saying R cannot be resolved as a variable. Now where is R being used: Quiz Location Custom Text About Delegate RSSS I have no idea what this means, this did not occur in xcode. Best Eric
 
ianJamesPiano
Code is Art
Profile
Posts: 2661
Reg: Feb 13, 2011
Palm Springs, C...
37,010
Fourm StarFourm StarFourm Star
like
02/17/12 02:04 PM (10 years ago)
Try this, report back if doesn't help :) If you run select Project -> Clean... on the eclipse menu it will remove and then regenerate the R.java file.
 
Esteban Mora
Aspiring developer
Profile
Posts: 3
Reg: Feb 14, 2012
Costa Rica
330
like
02/17/12 02:22 PM (10 years ago)
I have that same problem yesterday. It seems that in order to run the project you need to install Android 2.2 API 8 and Google API 8 (2.2) first. Then, when you create the project, specify the Google API 8 (2.2) as the base API of the project. Good luck!
 
The Fort Wayne Bri...
Aspiring developer
Profile
Posts: 35
Reg: Jan 24, 2012
Fort Wayne, IN
350
like
02/17/12 02:22 PM (10 years ago)
Not good, it still is bad...
 
ianJamesPiano
Code is Art
Profile
Posts: 2661
Reg: Feb 13, 2011
Palm Springs, C...
37,010
Fourm StarFourm StarFourm Star
like
02/17/12 02:28 PM (10 years ago)
Let us know if you do have Google Api 8 (2.2) installed correctly.
 
GoNorthWest
buzztouch Evangelist
Profile
Posts: 8197
Reg: Jun 24, 2011
Oro Valley, AZ
1,000,000
Fourm StarFourm StarFourm Star
like
02/17/12 03:20 PM (10 years ago)
Hi Eric, This generally has to do with the API level that you have selected for your project. Follow this guide to make sure your Eclipse environment is set up correct: http://www.buzztouch.com/resources/Setting_Up_Your_Android_Development_Environment_v1.3.pdf Let me know if it helps! Mark
 
Fred@mySkylla com
Android Fan
Profile
Posts: 5259
Reg: Oct 03, 2011
location unknow...
62,560
Fourm StarFourm StarFourm Star
like
02/17/12 05:12 PM (10 years ago)
My guide along with helpful documentation on the Buzztouch help tab well have you compiling in no time. @The . . . Bride, you're apparently BTv1.4. I have a section about BTv1.4 that will tell you about the correct API. www.myskylla.wordpress.com Fred
 
Fred@mySkylla com
Android Fan
Profile
Posts: 5259
Reg: Oct 03, 2011
location unknow...
62,560
Fourm StarFourm StarFourm Star
like
02/17/12 05:17 PM (10 years ago)
@Estaban, don't use the Android API Read my guide to understand and recognize the correct API or you'll get it correct sometimes, sometimes not. Fred
 
Jarcher
Aspiring developer
Profile
Posts: 21
Reg: Jul 08, 2011
London
510
like
06/03/12 05:38 PM (10 years ago)
I'm using MotoDev Studio 4 and get this error constantly when trying to export my Android App as an AOK File - I an using Google 2.2 and tried the clean project thing but always get the same error message Could this be a MotoDev error? Must you have KeyStore for it to work?
 

Login + Screen Name Required to Post

pointerLogin to participate so you can start earning points. Once you're logged in (and have a screen name entered in your profile), you can subscribe to topics, follow users, and start learning how to make apps like the pros.