Discussion Forums  >  Xcode, Errors, Installing, Configuring

Replies: 21    Views: 122

Chris from Stafford
Aspiring developer
Profile
Posts: 333
Reg: Oct 14, 2013
Stafford
5,730
04/15/17 01:41 PM (4 months ago)

Blank app

Downloaded the latest version of my app into xcode

Build successful on iPhone but when I open just a blank white screen

Help !
 
SmugWimp
Smugger than thou...
Profile
Posts: 6223
Reg: Nov 07, 2012
Tamuning, GU
80,480
like
04/15/17 04:03 PM (4 months ago)
Logs. Must see logs.

Cheers!

-- Smug
 
Chris from Staffor...
Aspiring developer
Profile
Posts: 333
Reg: Oct 14, 2013
Stafford
5,730
like
04/16/17 01:46 AM (4 months ago)
I wondered if I had just missed something obvious.

In the download was no buzz touch guide so I did everything from memory

Copied the plugins over and images before the build - just wondered if I missed an obvious step

Will post the logs later, unless as I said I've missed a vital step
 
Chris from Staffor...
Aspiring developer
Profile
Posts: 333
Reg: Oct 14, 2013
Stafford
5,730
like
04/16/17 03:56 AM (4 months ago)
Removed log as I think I know the answer

See below
 
AlanMac
Aspiring developer
Profile
Posts: 2591
Reg: Mar 05, 2012
Esher, UK
36,910
like
04/17/17 02:34 AM (4 months ago)
Hi Chris, I wrote some instructions (completely unofficial) for the iOS, might be worth looking at to help you see anything you missed when downloading & building a n app - http://limetimeapps.co.uk/appfiles/buzzlog/instructions.pdf

Looking at you log, a couple of things.

1) You've included your url's, I would edit & change them when publishing on a forum.

I see this mesage in your log - "appDelegate.rootApp.rootTheme is null". Not sure if it means something, might be worth setting a default theme?
 
Chris from Staffor...
Aspiring developer
Profile
Posts: 333
Reg: Oct 14, 2013
Stafford
5,730
like
04/17/17 06:17 AM (4 months ago)
I've looked at the folders and see that not all the plugins are in the build downloaded from Buzztouch

I think the Buzztouch compiler is faulty
 
AlanMac
Aspiring developer
Profile
Posts: 2591
Reg: Mar 05, 2012
Esher, UK
36,910
like
04/17/17 08:13 AM (4 months ago)
I am pretty sure it works, Buzztouch is tripping you up on something though. Are you aware the Buzztouch core plugins are now stored in a different place to 3rd party plugins?
 
Chris from Staffor...
Aspiring developer
Profile
Posts: 333
Reg: Oct 14, 2013
Stafford
5,730
like
04/17/17 11:50 AM (4 months ago)
I've downloaded the build for android and ran it and it says plugin not compiled. Build for iOS and i get a blank screen

tried with two different apps too and had same result

Update:

I just opened an older version of the app in Android Studio and it worked so I think it must be how it's compiled by Buzztouch
 
AlanMac
Aspiring developer
Profile
Posts: 2591
Reg: Mar 05, 2012
Esher, UK
36,910
like
04/17/17 12:13 PM (4 months ago)
I can assure you my projects download and compile. From what you have described, it sounds like one of the plugins in your project has not been updated to BT4.
 
Chris from Staffor...
Aspiring developer
Profile
Posts: 333
Reg: Oct 14, 2013
Stafford
5,730
like
04/17/17 04:42 PM (4 months ago)
The apps use menu with image - I guess it's not compatible with BT 4 then?
 
AlanMac
Aspiring developer
Profile
Posts: 2591
Reg: Mar 05, 2012
Esher, UK
36,910
like
04/18/17 02:51 AM (4 months ago)
Hi Chris, just to recap, I am pretty sure Menu with Image has been updated. I am also pretty sure the BT packaging (fyi, not compiling, that's what xCode does)and downloading for iOS is OK. It sounds like the only 3rd party plugin is Menu with Image. There are no errors or significant warnings you've told us about. Your log was reporting about 'no theme' a lot, not sure of the siugnificance, but I don't know if you added one to see if that changes anything. Is the menu with image the app 'home'? Could it be the way the plugin was dragged in to the project?

In short, I'm not sure why you are getting the problem. I feel as if we don't have enough info to easily pinpoint the issue. But I am trying to help, honest!

I'd start a new project, with one or two BT screens (no 3rd party screen), get that to work to give you some confidence and eliminate some of the theories, then maybe build up from there?

Alan
 
Chris from Staffor...
Aspiring developer
Profile
Posts: 333
Reg: Oct 14, 2013
Stafford
5,730
like
04/18/17 07:32 AM (4 months ago)
It's very odd as there's no obvious errors and in Xcode and Android Studio it says build successful But I'm getting missing plugin with Android and blank screen with iOS.

Menu with image is my home screen too.

I'll have a go and try a few different scenarios and see where it gets me

Thanks
 
Chris from Staffor...
Aspiring developer
Profile
Posts: 333
Reg: Oct 14, 2013
Stafford
5,730
like
04/18/17 11:05 AM (4 months ago)
I've built a simple app with just a simple link with menu with image and it works fine

I just can't understand why my old app won't work when downloaded with BT4

It's running fine when you download from app store and refresh for the latest version but not BT4 compiled in xcode (or android studio)

I'm baffled !
 
Chris from Staffor...
Aspiring developer
Profile
Posts: 333
Reg: Oct 14, 2013
Stafford
5,730
like
04/18/17 11:44 AM (4 months ago)
Right here's some interesting info:

I set up a simple menu with one link linking to my main menu

I then set the simple menu as my homepage and compiled and it worked!

So seems you cannot set a menu with image screen as the homepage - well I can't

Only other issue is it seems the YouTube Streamer plug-in isn't compatible with BT4 which is a shame

Update - set homepage back to my old menu re-compiled and now it works - I guess BT4 is just a bit buggy
 
AlanMac
Aspiring developer
Profile
Posts: 2591
Reg: Mar 05, 2012
Esher, UK
36,910
like
04/18/17 12:32 PM (4 months ago)
Glad you got there in the end.
 
Chris from Staffor...
Aspiring developer
Profile
Posts: 333
Reg: Oct 14, 2013
Stafford
5,730
like
04/19/17 11:53 AM (4 months ago)
Youtube streamer not working with BT 4 - this is the log

2017-04-19 19:51:47.606754+0100 izaakwalton[5947:1601826] WB_screen_menuImage: didSelectRowAtIndexPath: Selected Row: 6
2017-04-19 19:51:47.608097+0100 izaakwalton[5947:1601826] BT_application: getScreenDataByItemId: DEPRECATED 87EA322CC69E5DA80F322F0
2017-04-19 19:51:47.608347+0100 izaakwalton[5947:1601826] BT_application: getItemDataByItemId: "87EA322CC69E5DA80F322F0"
2017-04-19 19:51:47.608609+0100 izaakwalton[5947:1601826] BT_database: getBtItemWithId: "87EA322CC69E5DA80F322F0"
2017-04-19 19:51:47.608854+0100 izaakwalton[5947:1601826] BT_database: getItemsWithQuery: "SELECT * FROM tbl_btItems WHERE guid = '87EA322CC69E5DA80F322F0'"
2017-04-19 19:51:47.615346+0100 izaakwalton[5947:1601826] BT_application: itemType is AT_youtube for item with nickname: "Freemasonry Video" and itemId: 87EA322CC69E5DA80F322F0
2017-04-19 19:51:47.615790+0100 izaakwalton[5947:1601826] WB_screen_menuImage: handleTapToLoadScreen (BT_viewController) loading nickname: "Freemasonry Video" itemId: 87EA322CC69E5DA80F322F0 itemType: AT_youtube
2017-04-19 19:51:47.616147+0100 izaakwalton[5947:1601826] BT_application: getViewControllerForScreen nickname: "Freemasonry Video" itemId: 87EA322CC69E5DA80F322F0 type: AT_youtube
2017-04-19 19:51:47.617729+0100 izaakwalton[5947:1601826] BT_application: getViewControllerForScreen: NO STORYBOARD for "AT_youtube", looking for .XIB instead
2017-04-19 19:51:47.618390+0100 izaakwalton[5947:1601826] AT_youtube: INIT
2017-04-19 19:51:47.618705+0100 izaakwalton[5947:1601826] BT_navController: pushViewController
2017-04-19 19:51:47.620072+0100 izaakwalton[5947:1601826] AT_youtube: prefersStatusBarHidden
2017-04-19 19:51:47.629877+0100 izaakwalton[5947:1601826] WB_screen_menuImage: viewWillDisappear (BT_viewController)
2017-04-19 19:51:47.630096+0100 izaakwalton[5947:1601826] WB_screen_menuImage: fadeOutOnExit (BT_viewController):
2017-04-19 19:51:47.631299+0100 izaakwalton[5947:1601826] AT_youtube: viewDidLoad
2017-04-19 19:51:47.631434+0100 izaakwalton[5947:1601826] AT_youtube: viewDidLoad (BT_viewController)
2017-04-19 19:51:49.008489+0100 izaakwalton[5947:1601826] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** setObjectForKey: object cannot be nil (key: iurl)'
*** First throw call stack:
(0x18201afd8 0x180a7c538 0x181efe518 0x10016f9d8 0x10016fe70 0x10013520c 0x100135090 0x188149f9c 0x188161a28 0x1882e62a0 0x188200c4c 0x1882008b4 0x188200818 0x188147158 0x185337274 0x18532bde8 0x18532bca8 0x1852a7360 0x1852ce3c0 0x18813c7a0 0x181fc89a0 0x181fc6628 0x181fc6a74 0x181ef6d94 0x183960074 0x1881af130 0x10013d504 0x180f0559c)
libc++abi.dylib: terminating with uncaught exception of type NSException
 
AlanMac
Aspiring developer
Profile
Posts: 2591
Reg: Mar 05, 2012
Esher, UK
36,910
like
04/19/17 12:13 PM (4 months ago)
I'm not aware of a plugin called "youtube streamer" and I checked the plugin market too. Might it have been removed?
 
AlanMac
Aspiring developer
Profile
Posts: 2591
Reg: Mar 05, 2012
Esher, UK
36,910
like
04/19/17 12:18 PM (4 months ago)
The log seems to be indicating the problem is with something called iurl being set to nil. Could that mean the url to play is blank?
 
Chris from Staffor...
Aspiring developer
Profile
Posts: 333
Reg: Oct 14, 2013
Stafford
5,730
like
04/19/17 12:36 PM (4 months ago)
Yes it's been removed

Great plugin which allowed you to stream youtube videos

Sadly there doesn't seem to be a way to do it in as good a way as this plugin & I used it in a couple of apps and now need to find another way of showing my videos
 
Red Dog
buzztouch Evangelist
Profile
Posts: 805
Reg: Jun 16, 2011
Southern Califo...
18,800
like
04/19/17 01:17 PM (4 months ago)
I have not seen Suvinay Pawa on the forums in a year or so. His Plugin.
I'm sure someone (not me) can create a new plugin to replace it.
 
Chris from Staffor...
Aspiring developer
Profile
Posts: 333
Reg: Oct 14, 2013
Stafford
5,730
like
04/20/17 12:39 PM (4 months ago)
Finally thought I was getting somewhere

Run app on iPhone ok - but run app on iPad Blank Screen !
 
AlanMac
Aspiring developer
Profile
Posts: 2591
Reg: Mar 05, 2012
Esher, UK
36,910
like
04/25/17 05:36 AM (3 months ago)
I just got myself into and out of a similar situation with the blank home screen. I was looking at a different problem, which I posted about here:

https://www.buzztouch.com/forum/thread.php?fid=EF969538E8F0953D5362671&tid=EF969538E8F0953D5362671
 

Login + Screen Name Required to Post

pointerLogin to participate so you can start earning points. Once you're logged in (and have a screen name entered in your profile), you can subscribe to topics, follow users, and start learning how to make apps like the pros.